1
Vote

Slow start-up time with OverOps agent

Hi guys,

We are facing an issue on our tomcat startup, when adding the agent is impacting more than 30% on server startup.

How can this be solved or improved?

Thanks!

Comments 1 comment
  • 1
    Comment actions Permalink

    Hi Sid!

    The reason why tomcat needs longer to startup is that the agent is trying to instrument all the classes that are being loaded when the application is starting, and this takes time.

    A possible solution for this issue is to hold back our agent until after the application has started.

     

    There are two (2) properties which can achieve that. Both can be found in our documentation (https://doc.overops.com/docs/agent-properties).

    The “takipi.boot.time” and "takipi.disable.exception.handling.time".

    They both will get the same result, only that the "takipi.disable.exception.handling.time" property will trigger a callback as well.

    Best approach is to set the value to a time after you application normally starts.For example: If your app usually starts after 15 min , set the “takipi.boot.time” flag value to 20 min.

    Hope that helps!

Please sign in to leave a comment.

Join conversation